需要支持?

如果通过文档没办法解决您的问题,请提交工单获取我们的支持!

易语言例子

<pre class="calibre14">```
.版本 2
.支持库 dp1
.支持库 spec

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
.局部变量 time_stamp, 文本型
.局部变量 sign, 文本型
.局部变量 url, 文本型
.局部变量 data, 文本型

url = “https://api.youmaitu.cn/api/yiyan”  ' API链接
time_stamp = “time_stamp=” + 时间_取现行时间戳 (真)  ' 10位时间戳
sign = 取数据摘要 (到字节集 (“api_id=10000001&secretKey=15297b469cbc9b9b5a7b9bb7efe122a5” + “&” + time_stamp))  ' //生成签名(Apiid、secretKey、time_stamp)组合生成MD5
data = “api_key=8bbc08144b4ed76a&sign=” + sign + “&” + time_stamp  ' 参数组合(apiKey、时间戳(若API有参数也可以写到这里))
.计次循环首 (10, )  ' get访问
    调试输出 (编码_Utf8到Ansi (网页_访问_对象 (url + “?” + data)))
.计次循环尾 ()
.计次循环首 (10, )  ' post访问
    调试输出 (编码_Utf8到Ansi (网页_访问_对象 (url, 1, data, )))
.计次循环尾 ()
返回 (0)  ' 可以根据您的需要返回任意数值

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧